use strict;
my $str = 'Name: Oski, Year: ???, SID: 123456789
Name: Leon, Year: Senior, SID: 382049283 (this is just something random)
Name: Peter, Year: Junior, SID: 329840020 (also something random)
';
my $regex = qr/.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}