package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*`)
var str = `Name: Oski, Year: ???, SID: 123456789
Name: Leon, Year: Senior, SID: 382049283 (this is just something random)
Name: Peter, Year: Junior, SID: 329840020 (also something random)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}