import re
regex = re.compile(r"^(?<ipaddress>[^\s]+)\s-\s.*\s\[.*\]\s\"\".*\"\"\s2[0-9][0-9]\s[0-9]*\s\"\"-\"\"\s\"\".*\"\"\s\"\".*\"\"[^\n]*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("123.456.789.01 - - [28/Apr/2024:08:44:37 +0200] \"GET /folder1/file HTTP/1.1\" 200 368 \"-\" \"python-requests/2.25.1\" \"-\"\n"
"123.456.789.01 - - [28/Apr/2024:09:47:34 +0200] \"GET /folder1/file HTTP/1.1\" 200 312 \"https://www.came-from-here.abcd/\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"\n"
"123.456.789.01 - SillyUserName [28/Apr/2024:13:18:12 +0200] \"GET /folder2/Start.html HTTP/1.1\" 200 10269 \"https://www.came-from-there.abcd/folder2/start.html\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")