package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\\TABASIPP\\Prod_Data\\appr\\data\\(?<date>\d\d\d\d-\d\d-\d\d)`)
var str = `\\TABASIPP\Prod_Data\appr\data\2022-06-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}