re = /\\\\TABASIPP\\Prod_Data\\appr\\data\\(?<date>\d\d\d\d-\d\d-\d\d)/m
str = '\\\\TABASIPP\\Prod_Data\\appr\\data\\2022-06-01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end