// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\\\TABASIPP\\Prod_Data\\appr\\data\\(?<date>\d\d\d\d-\d\d-\d\d)").unwrap();
let string = "\\\\TABASIPP\\Prod_Data\\appr\\data\\2022-06-01";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}