import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d++(?! ?(?:red|green)).*(\\bwarehouse\\b)";
final String string = "123 warehouse\n"
+ "124 token warehouse.\n"
+ "153token token abc123; etc. - warehouse \n"
+ "223abdc token abc green warehouse\n\n"
+ "53red warehouse.\n"
+ "323 green token token etc warehouse.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}