$re = '/\d++(?! ?(?:red|green)).*(\bwarehouse\b)/m';
$str = '123 warehouse
124 token warehouse.
153token token abc123; etc. - warehouse
223abdc token abc green warehouse
53red warehouse.
323 green token token etc warehouse.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);