const regex = /\d++(?! ?(?:red|green)).*(\bwarehouse\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d++(?! ?(?:red|green)).*(\\bwarehouse\\b)', 'gm')
const str = `123 warehouse
124 token warehouse.
153token token abc123; etc. - warehouse
223abdc token abc green warehouse
53red warehouse.
323 green token token etc warehouse.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}