import re
regex = re.compile(r"\d++(?! ?(?:red|green)).*(\bwarehouse\b)", flags=re.MULTILINE)
test_str = ("123 warehouse\n"
"124 token warehouse.\n"
"153token token abc123; etc. - warehouse \n"
"223abdc token abc green warehouse\n\n"
"53red warehouse.\n"
"323 green token token etc warehouse.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")