#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\/\*\*((?:[^*]|\s|\*[^/])*)\*\/)?\s*([a-zA-Z]+):\s*"([^"]*)""
Local $sString = " /**" & @CRLF & _
" * ### Summary" & @CRLF & _
" *" & @CRLF & _
" * Method or function is not implemented" & @CRLF & _
" *" & @CRLF & _
" * ### Description" & @CRLF & _
" *" & @CRLF & _
" * This error is used to flag methods or functions that are not yet implemented." & @CRLF & _
" * @since 0.1.5" & @CRLF & _
" */" & @CRLF & _
" notImplemented:" & @CRLF & _
" "Not implemented"," & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * ### Summary" & @CRLF & _
" *" & @CRLF & _
" * Method is abstract" & @CRLF & _
" *" & @CRLF & _
" * ### Description" & @CRLF & _
" *" & @CRLF & _
" * This error is used to implement abstract methods. Mostly used for interfaces." & @CRLF & _
" * @since 0.1.5" & @CRLF & _
" */" & @CRLF & _
" abstractMethod:" & @CRLF & _
" "Abstract method"," & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * ### Summary" & @CRLF & _
" *" & @CRLF & _
" * An assertion failed" & @CRLF & _
" *" & @CRLF & _
" * ### Description" & @CRLF & _
" *" & @CRLF & _
" * This error is triggered when an assertion fails" & @CRLF & _
" *" & @CRLF & _
" * @see {@link gpf.assert}" & @CRLF & _
" * @see {@link gpf.asserts}" & @CRLF & _
" * @since 0.1.5" & @CRLF & _
" */" & @CRLF & _
" assertionFailed:" & @CRLF & _
" "Assertion failed: {message}"," & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" * ### Summary" & @CRLF & _
" *" & @CRLF & _
" * Method or function was called with an invalid parameter" & @CRLF & _
" *" & @CRLF & _
" * ### Description" & @CRLF & _
" *" & @CRLF & _
" * This error is used when a parameter is invalid" & @CRLF & _
" * @since 0.1.5" & @CRLF & _
" */" & @CRLF & _
" invalidParameter:" & @CRLF & _
" "Invalid parameter"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")