import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/\\*\\*((?:[^*]|\\s|\\*[^/])*)\\*\\/)?\\s*([a-zA-Z]+):\\s*\"([^\"]*)\"";
final String string = " /**\n"
+ " * ### Summary\n"
+ " *\n"
+ " * Method or function is not implemented\n"
+ " *\n"
+ " * ### Description\n"
+ " *\n"
+ " * This error is used to flag methods or functions that are not yet implemented.\n"
+ " * @since 0.1.5\n"
+ " */\n"
+ " notImplemented:\n"
+ " \"Not implemented\",\n\n"
+ " /**\n"
+ " * ### Summary\n"
+ " *\n"
+ " * Method is abstract\n"
+ " *\n"
+ " * ### Description\n"
+ " *\n"
+ " * This error is used to implement abstract methods. Mostly used for interfaces.\n"
+ " * @since 0.1.5\n"
+ " */\n"
+ " abstractMethod:\n"
+ " \"Abstract method\",\n\n"
+ " /**\n"
+ " * ### Summary\n"
+ " *\n"
+ " * An assertion failed\n"
+ " *\n"
+ " * ### Description\n"
+ " *\n"
+ " * This error is triggered when an assertion fails\n"
+ " *\n"
+ " * @see {@link gpf.assert}\n"
+ " * @see {@link gpf.asserts}\n"
+ " * @since 0.1.5\n"
+ " */\n"
+ " assertionFailed:\n"
+ " \"Assertion failed: {message}\",\n\n"
+ " /**\n"
+ " * ### Summary\n"
+ " *\n"
+ " * Method or function was called with an invalid parameter\n"
+ " *\n"
+ " * ### Description\n"
+ " *\n"
+ " * This error is used when a parameter is invalid\n"
+ " * @since 0.1.5\n"
+ " */\n"
+ " invalidParameter:\n"
+ " \"Invalid parameter\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}