# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\/\*\*((?:[^*]|\s|\*[^/])*)\*\/)?\s*([a-zA-Z]+):\s*\"([^\"]*)\""
test_str = (" /**\n"
" * ### Summary\n"
" *\n"
" * Method or function is not implemented\n"
" *\n"
" * ### Description\n"
" *\n"
" * This error is used to flag methods or functions that are not yet implemented.\n"
" * @since 0.1.5\n"
" */\n"
" notImplemented:\n"
" \"Not implemented\",\n\n"
" /**\n"
" * ### Summary\n"
" *\n"
" * Method is abstract\n"
" *\n"
" * ### Description\n"
" *\n"
" * This error is used to implement abstract methods. Mostly used for interfaces.\n"
" * @since 0.1.5\n"
" */\n"
" abstractMethod:\n"
" \"Abstract method\",\n\n"
" /**\n"
" * ### Summary\n"
" *\n"
" * An assertion failed\n"
" *\n"
" * ### Description\n"
" *\n"
" * This error is triggered when an assertion fails\n"
" *\n"
" * @see {@link gpf.assert}\n"
" * @see {@link gpf.asserts}\n"
" * @since 0.1.5\n"
" */\n"
" assertionFailed:\n"
" \"Assertion failed: {message}\",\n\n"
" /**\n"
" * ### Summary\n"
" *\n"
" * Method or function was called with an invalid parameter\n"
" *\n"
" * ### Description\n"
" *\n"
" * This error is used when a parameter is invalid\n"
" * @since 0.1.5\n"
" */\n"
" invalidParameter:\n"
" \"Invalid parameter\"\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.