const regex = /(?:\/\*\*((?:[^*]|\s|\*[^/])*)\*\/)?\s*([a-zA-Z]+):\s*"([^"]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/\\*\\*((?:[^*]|\\s|\\*[^\/])*)\\*\\\/)?\\s*([a-zA-Z]+):\\s*"([^"]*)"', 'g')
const str = ` /**
* ### Summary
*
* Method or function is not implemented
*
* ### Description
*
* This error is used to flag methods or functions that are not yet implemented.
* @since 0.1.5
*/
notImplemented:
"Not implemented",
/**
* ### Summary
*
* Method is abstract
*
* ### Description
*
* This error is used to implement abstract methods. Mostly used for interfaces.
* @since 0.1.5
*/
abstractMethod:
"Abstract method",
/**
* ### Summary
*
* An assertion failed
*
* ### Description
*
* This error is triggered when an assertion fails
*
* @see {@link gpf.assert}
* @see {@link gpf.asserts}
* @since 0.1.5
*/
assertionFailed:
"Assertion failed: {message}",
/**
* ### Summary
*
* Method or function was called with an invalid parameter
*
* ### Description
*
* This error is used when a parameter is invalid
* @since 0.1.5
*/
invalidParameter:
"Invalid parameter"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}