using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w+(?:\((?:(?:[^()]+|(?R))*)\)),?)+";
string input = @"Func(1,2),one(Sub(1,Func(true)),2),two(Sub(1,false),3)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}