$re = '/(?:\w+(?:\((?:(?:[^()]+|(?R))*)\)),?)+/U';
$str = 'Func(1,2),one(Sub(1,Func(true)),2),two(Sub(1,false),3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);