package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(?:\w+(?:\((?:(?:[^()]+|(?R))*)\)),?)+`)
var str = `Func(1,2),one(Sub(1,Func(true)),2),two(Sub(1,false),3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}