// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?U)(?:\w+(?:\((?:(?:[^()]+|(?R))*)\)),?)+").unwrap();
let string = "Func(1,2),one(Sub(1,Func(true)),2),two(Sub(1,false),3)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}