#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)--(.*?)--.*?(-pre-(.*?)-\/pre-)+"
Local $sString = "--comments--" & @CRLF & _
"list of comments" & @CRLF & _
"-pre-" & @CRLF & _
"comment 1" & @CRLF & _
"-/pre-" & @CRLF & _
"" & @CRLF & _
"-pre-" & @CRLF & _
"comment 2" & @CRLF & _
"-/pre-" & @CRLF & _
"" & @CRLF & _
"--Answers--" & @CRLF & _
"list of Answers" & @CRLF & _
"-pre-" & @CRLF & _
"Answer 1" & @CRLF & _
"-/pre-" & @CRLF & _
"" & @CRLF & _
"-pre-" & @CRLF & _
"Answer 2" & @CRLF & _
"-/pre-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")