using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--(.*?)--.*?(-pre-(.*?)-\/pre-)+";
string input = @"--comments--
list of comments
-pre-
comment 1
-/pre-
-pre-
comment 2
-/pre-
--Answers--
list of Answers
-pre-
Answer 1
-/pre-
-pre-
Answer 2
-/pre-";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}