import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--(.*?)--.*?(-pre-(.*?)-\\/pre-)+";
final String string = "--comments--\n"
+ "list of comments\n"
+ "-pre-\n"
+ "comment 1\n"
+ "-/pre-\n\n"
+ "-pre-\n"
+ "comment 2\n"
+ "-/pre-\n\n"
+ "--Answers--\n"
+ "list of Answers\n"
+ "-pre-\n"
+ "Answer 1\n"
+ "-/pre-\n\n"
+ "-pre-\n"
+ "Answer 2\n"
+ "-/pre-";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}