re = /--(.*?)--.*?(-pre-(.*?)-\/pre-)+/
str = '--comments--
list of comments
-pre-
comment 1
-/pre-
-pre-
comment 2
-/pre-
--Answers--
list of Answers
-pre-
Answer 1
-/pre-
-pre-
Answer 2
-/pre-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end