#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\t\n]+(?=[^][]*(?:(\[(?:[^][]++|(?1))*])[^][]*)*])"
Local $sString = "settings:a [" & @CRLF & _
" a:[" & @CRLF & _
" a:a" & @CRLF & _
" b:b" & @CRLF & _
" ]" & @CRLF & _
" b:[" & @CRLF & _
" a:a" & @CRLF & _
" b:b" & @CRLF & _
" ]" & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
"settings:b [" & @CRLF & _
" a:[" & @CRLF & _
" a:a" & @CRLF & _
" b:b" & @CRLF & _
" ]" & @CRLF & _
"]"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)