re = /[\t\n]+(?=[^][]*(?:(\[(?:[^][]++|(?1))*])[^][]*)*])/m
str = 'settings:a [
a:[
a:a
b:b
]
b:[
a:a
b:b
]
]
settings:b [
a:[
a:a
b:b
]
]'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result