const regex = /[\t\n]+(?=[^][]*(?:(\[(?:[^][]++|(?1))*])[^][]*)*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\t\\n]+(?=[^][]*(?:(\\[(?:[^][]++|(?1))*])[^][]*)*])', 'gm')
const str = `settings:a [
a:[
a:a
b:b
]
b:[
a:a
b:b
]
]
settings:b [
a:[
a:a
b:b
]
]`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);