import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\t\\n]+(?=[^][]*(?:(\\[(?:[^][]++|(?1))*])[^][]*)*])";
final String string = "settings:a [\n"
+ " a:[\n"
+ " a:a\n"
+ " b:b\n"
+ " ]\n"
+ " b:[\n"
+ " a:a\n"
+ " b:b\n"
+ " ]\n"
+ "]\n\n"
+ "settings:b [\n"
+ " a:[\n"
+ " a:a\n"
+ " b:b\n"
+ " ]\n"
+ "]";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}