package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)Looking: (.*?#\d+)`)
var str = `fgdshdfgsLooking: 3j #123
Looking: avb456j #13fgfddg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}