const regex = /Looking: (.*?#\d+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Looking: (.*?#\\d+)', 'gms')
const str = `fgdshdfgsLooking: 3j #123
Looking: avb456j #13fgfddg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}