re = /Looking: (.*?#\d+)/m
str = 'fgdshdfgsLooking: 3j #123
Looking: avb456j #13fgfddg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end