$re = '/Looking: (.*?#\d+)/ms';
$str = 'fgdshdfgsLooking: 3j #123
Looking: avb456j #13fgfddg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);