import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]+[a-zA-Z0-9._]+@[a-z]+\\.[a-z.]{2,}$";
final String string = "jhongranados@gmail.com\n"
+ "hola@gmail.com\n"
+ "buenas.com\n"
+ "@julio.com\n"
+ "123hhs@\n"
+ "1jh.com\n"
+ "1jh@s.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}