import re
regex = re.compile(r"^[a-zA-Z]+[a-zA-Z0-9._]+@[a-z]+\.[a-z.]{2,}$", flags=re.MULTILINE)
test_str = ("jhongranados@gmail.com\n"
"hola@gmail.com\n"
"buenas.com\n"
"@julio.com\n"
"123hhs@\n"
"1jh.com\n"
"1jh@s.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")