$re = '/^[a-zA-Z]+[a-zA-Z0-9._]+@[a-z]+\.[a-z.]{2,}$/m';
$str = 'jhongranados@gmail.com
hola@gmail.com
buenas.com
@julio.com
123hhs@
1jh.com
1jh@s.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);