re = /^[a-zA-Z]+[a-zA-Z0-9._]+@[a-z]+\.[a-z.]{2,}$/m
str = 'jhongranados@gmail.com
hola@gmail.com
buenas.com
@julio.com
123hhs@
1jh.com
1jh@s.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end