using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w)|(.)";
string substitution = @"\1";
string input = @"alan dos santos silva";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}