use strict;
my $str = 'alan dos santos silva';
my $regex = qr/(\b\w)|(.)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";