# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.(?:\. *| +))([\p{L}\p{N}\p{M}]+)/$2 $1/gm;t' <<< "Ą.BČ
Ą.BČ D Ę
Ą. BČ
Ą. BČ D Ę
Ą BČ
Ą BČ D Ę
Examples below should not be affected.
ĄB ČD DĘ"