re = /^(.(?:\. *| +))([\p{L}\p{N}\p{M}]+)/m
str = 'Ą.BČ
Ą.BČ D Ę
Ą. BČ
Ą. BČ D Ę
Ą BČ
Ą BČ D Ę
Examples below should not be affected.
ĄB ČD DĘ'
subst = '$2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result