package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.(?:\. *| +))([\p{L}\p{N}\p{M}]+)`)
var str = `Ą.BČ
Ą.BČ D Ę
Ą. BČ
Ą. BČ D Ę
Ą BČ
Ą BČ D Ę
Examples below should not be affected.
ĄB ČD DĘ`
var substitution = "$2 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}