import Foundation
let pattern = #"^(.(?:\. *| +))([\p{L}\p{N}\p{M}]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ą.BČ
Ą.BČ D Ę
Ą. BČ
Ą. BČ D Ę
Ą BČ
Ą BČ D Ę
Examples below should not be affected.
ĄB ČD DĘ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)