# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/;\s+(.*?)(?=\r?\n|$)/;$1/gs;t' <<< " asd signal1;/* '<Root>/explain1' */
asd signal2;/* '<Root>/explain2' */
asd signal3;
/* '<Root>/explain3' */
asd signal4;
/* '<Root>/explain4' */
asd signal5;/* '<Root>/explain5' */"