$re = '/;\s+(.*?)(?=\r?\n|$)/s';
$str = ' asd signal1;/* \'<Root>/explain1\' */
asd signal2;/* \'<Root>/explain2\' */
asd signal3;
/* \'<Root>/explain3\' */
asd signal4;
/* \'<Root>/explain4\' */
asd signal5;/* \'<Root>/explain5\' */';
$subst = ";$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;