import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";\\s+(.*?)(?=\\r?\\n|$)";
final String string = " asd signal1;/* '<Root>/explain1' */\n"
+ " asd signal2;/* '<Root>/explain2' */\n"
+ " asd signal3;\n"
+ " /* '<Root>/explain3' */\n"
+ " asd signal4;\n"
+ " /* '<Root>/explain4' */\n"
+ " asd signal5;/* '<Root>/explain5' */";
final String subst = ";$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}