import Foundation
let pattern = #";\s+(.*?)(?=\r?\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
asd signal1;/* '<Root>/explain1' */
asd signal2;/* '<Root>/explain2' */
asd signal3;
/* '<Root>/explain3' */
asd signal4;
/* '<Root>/explain4' */
asd signal5;/* '<Root>/explain5' */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)