package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<\s*\/?\s*br[^>]*>|<\s*\/?\s*p[^>]*>|\n`)
var str = `<h1>Heading</h1>
<br>
<br />
<a href="#">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>
<Br>
<p title='test>`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}