# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\s*\/?\s*br[^>]*>|<\s*\/?\s*p[^>]*>|\n"
test_str = ("<h1>Heading</h1>\n"
"<br>\n"
"<br />\n"
"<a href=\"#\">hyperlink</a>\n"
"<p></p>\n"
"<p>paragraph1</p>\n"
"<p>paragraph2</p>\n"
"<Br>\n"
"<p title='test>")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.