$re = '/<\s*\/?\s*br[^>]*>|<\s*\/?\s*p[^>]*>|\n/mi';
$str = '<h1>Heading</h1>
<br>
<br />
<a href="#">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>
<Br>
<p title=\'test>';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;