using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{% image (([a-z]|[A-Z]|[0-9]|\.|_|=|-|'|\s)*)(?<!loading='lazy')\s* %}";
string substitution = @"";
string input = @"{% image self.hero_image fill-803x300 as hero_image loading='lazy' %}
{% image self.hero_image fill-803x300 as hero_image %}
{% image self.hero_image fill-803x300 as hero_image lo %}
{% image self.image_desktop fill-480x776.noauto as image_480 %}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}