re = /{% image (([a-z]|[A-Z]|[0-9]|\.|_|=|-|'|\s)*)(?<!loading='lazy')\s* %}/m
str = '{% image self.hero_image fill-803x300 as hero_image loading=\'lazy\' %}
{% image self.hero_image fill-803x300 as hero_image %}
{% image self.hero_image fill-803x300 as hero_image lo %}
{% image self.image_desktop fill-480x776.noauto as image_480 %}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result