const regex = /{% image (([a-z]|[A-Z]|[0-9]|\.|_|=|-|'|\s)*)(?<!loading='lazy')\s* %}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{% image (([a-z]|[A-Z]|[0-9]|\\.|_|=|-|\'|\\s)*)(?<!loading=\'lazy\')\\s* %}', 'gm')
const str = `{% image self.hero_image fill-803x300 as hero_image loading='lazy' %}
{% image self.hero_image fill-803x300 as hero_image %}
{% image self.hero_image fill-803x300 as hero_image lo %}
{% image self.image_desktop fill-480x776.noauto as image_480 %}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);